Dear Diary: Running Trac and upgrading to Ubuntu Server 14.04

I’m a fairly heavy user of trac. I’ve got various software projects I organize using trac. I decided to upgrade one of my Ubuntu 12.04 servers to Ubuntu 14.04 and of course ran in to the typical apache2 headaches that are born out of this particular transition.

After remembering to rename my virtual host files with .conf extensions (I find that change annoying as hell on its own), I kept running aground with an Internal Server Error message to which I couldn’t even find a hint in my logs, even after cranking up the verbosity.

 

Screen Shot 2014-09-17 at 6.00.23 PM

 

SIGH

Read more “Dear Diary: Running Trac and upgrading to Ubuntu Server 14.04”

My Diary: on running PHP 5.5+ & Apache 2.4 on Ubuntu 12.04

I’ve been working on migrating a Moodle 2.4+ installation from a rickety old Ubuntu 10.04 server on Amazon EC2 to a fresh machine as I can’t seem to update the original server to 12.04, which has newer PHP packages I require to run Moodle 2.6+, which I want specifically due to a user stats plugin I want installed.. So with one thing leading to another, I ran aground recently when I upgraded Ubuntu’s 12.04 Apache2 version to Apache 2.4 (from some PPA). This resulted in my site no longer working, it pretty much just said access denied. This was due to some new Apache security setting that my migrated Virtual Host config lacked.

Should I run in to later, I’m throwing down steps I’ll follow to avoid the same ice bergs that costs me to burn a little more coffee than I’d prefer….

Step 1) Install PHP5.5/Apache2.4 via PPA:  sudo add-apt-repository ppa:ondrej/php5;sudo apt-get update;apt-get -y upgrade

Step 2) Check VHost Config’s Directory sections, add  Require all granted  if not present.

Here’s the key stuff I used to find this approach in the first place: http://askubuntu.com/questions/109404/how-do-i-install-latest-php-in-supported-ubuntu-versions-like-5-4-x-in-ubuntu-1